How to connect My Energica App to Energica electric motorcycle

This question was popping up a lot lately and I know in the past some software issues were preventing this connection to restore properly. Also when you get a new bike or a new phone (not sure which is more likely) you would have to go through these steps all over again. And they can be a bit confusing.

While making a quick video to explain more it looks like, at least for iOS, most issues are resolved. The hickup I still see is that the state of the connect button in the top right corner is messed up. Not that a big issue, sometimes you just have to press it once to recover and then once more to actually connect. I have yet to try the Android version.

The trick I describe in the video is to reset the connection settings on both the phone and the bike and then relaunch the 2 together to let them find each other.

Reset connection on bike can be done from the menu, go to settings > connectivity and then go to the right tab and pick the reset option. The MAC address on top should be all 00 in order for this to have worked. Make sure you do this with the app not running and vice versa, so one at once. Also without anyone else having the my energica app running on their phone nearby. You can restart the bike though that shouldn’t be needed. It’s easier to keep the menu open so you can see if it linked or not. If it fails after all you can always still restart the bike. But it should keep advertising while it’s running (not on GO, just key ON).

Reset connection on phone is done from the hamburger menu on the left top of the My Energica app and then go to settings and there pick the lowest option that has a button RESET. Touch it and you’ll see a message that the connection has been reset. Here I would advise to kill the app from running apps before connecting again. For that just swipe bottom to top to see running apps and swipe the MyEnergica app out of this overview.

There were some messages about bikes delivered without the bluetooth module. You’ll always have the bluetooth icon on the screen in the bottom left corner, even if that module is missing. It just would never turn blue, indicating a “connection” is made. You can check by taking one of the tank covers off to see if you have the module. Maybe they were indeed never installed on some orders due to shortage.

There is a manual available from Energica, I haven’t read it so I can’t say if it is any good but it’s there if you need.

Geef een reactie

Vul je gegevens in of klik op een icoon om in te loggen.

WordPress.com logo

Je reageert onder je WordPress.com account. Log uit /  Bijwerken )

Twitter-afbeelding

Je reageert onder je Twitter account. Log uit /  Bijwerken )

Facebook foto

Je reageert onder je Facebook account. Log uit /  Bijwerken )

Verbinden met %s